Welcome to Second Life

By Dr Bryan Carter, Central Missouri University

Welcome to SL! A whole bunch of us really like it here.

SL isn't a game. It's an environment. It CONTAINS some games, though. And yes, SL is pretty bewildering and confusing at first. Even daunting. Probably much more than you expected when you signed up. That's alright. It's normal. We all go through that when we start here. It passes fairly quickly, all things considered.

THE WELCOME AREA

~~~~~~~~~~~~~~~

Initially, you will start off in the WA (what we call the Welcome Area). It's one of the laggiest places on SL, so don't take the sluggish performance there too badly.

A lot of people come to hang out at the Welcome Area. Some are there to help you. Some are there to chat, and some are there to show off or get in the way. Pretty much like any public space.

GETTING HELP

~~~~~~~~~~~

Most folks will help you. Some are paid in SL money (L$) to do it. Those are people who have the title Live Helper or Mentor above their names.

Other people have formed private organisations like the NCI or the Shelter that assist with this task. Be nice to the folks helping out. Many of them are doing it for no other reason than they want to see you have a good time and fit in comfortably and make some friends.

‘

If you're shy about grabbing random people and asking them questions, try LIVE HELP (select the HELP menu at the top of your screen, then select LIVE HELP). That will put you in touch with a team of dedicated and cool volunteers who are happy to help answer questions.

MONEY

~~~~~~

You don't HAVE to have money to have a good time in SL. Unless the only sorts of things you find fun are the sort that cost money, that is. Money's nice enough to have, but there's plenty free and cheap fun to be had.

### Frequently Asked Questions ###

________________________________________

Q> "What do I do here?"

Second Life is like a Massively Multiplayer 3D Playground (or a 3D MUSH if you are familiar with that term).

It's a 3D canvas where people can create things in a shared space with other people.

SL is not exactly a game, as there is nothing here to win, and there are no specific tasks that you are expected to do. The only goals here are the ones you make for yourself.

If you're not sure what to do first, try these suggestions:

- Fly around and explore the world to see what other people have created.

- Check out the events list by pressing the (Events ) button at the bottom of your screen.

- Start building in a sandbox (i.e. in regions Morris, Cordova, Goguen, and others).

- Make friends with people in the Welcome Area and ask them where to find good places to visit.

________________________________________

Q> "How do I make money?"

The most common ways to make money include:

- creating content and selling it to other residents (i.e. objects, clothes, scripts, animations, textures, etc)

- winning a cash prize at an event (i.e.: bingo, trivia, Tringo, etc)

- doing contract work for another resident

- hosting an educational event which educates other residents about how to use Second Life

If all else fails, you can purchase L$ with US$ from third party currency exchange sites, listed under the menu: Help > Purchase L$...

Note that there are no 'missions' or 'loot' you can gather extra money from like in MMORPGs. Your only sources for money are from other residents or from your weekly stipend.

________________________________________

Q> "Why is my display so slow?"

SL is a very complex 3d application which will consume a large chunk (if not all) of your computer's CPU, memory, video, and network resources, more so even than nearly all other 3d programs.

Most games have pre-compiled maps, which is why they run so much faster. SL is too dynamic to be able to use these shortcuts, so it will run a bit slower than those games.

Fortunately, you don't need a high frame rate to enjoy SL. 10-15 FPS is typical and quite usable here.

If you are suffering from unbearable lag or instability, or are curious how to tune your performance, talk with your instructor.

Q> "How do I detach something from my head?" (or other body part)

Your avatar can have up to 30 objects attached to it's skeleton. This is a great way to customize your look, but sometimes you attach things by accident.

To remove an attachment, try each of these steps in order, until you manage to detach the object:

- right click on the object (make sure the point on your mouse is right on the specific object surface), choose "Detach"

- go to the Edit menu, select "Detach Object", then pick the highlighted skeletal region where the object is attached

- right click on your avatar, select "Take Off>" then "Detach All" (this will remove all attachments)

If all else fails, try relogging. It may just be "ghosted".

________________________________________

Q> "Where do I shop for new clothes?" (or other things)

- Click the ( Find ) button at the bottom of your screen

- Select the "Places" tab

- In the search box, type a keyword for what you're searching for (ie clothes)

________________________________________

Q> "How do I buy something?"

Typically, you just right click the object and choose "Buy" from the pie menu.

If "Buy" is not available, but "Pay" is, then you are probably dealing with a scripted vendor. See next question =)

Some things to keep in mind when purchasing things:

- Be careful of spending too much money when you first arrive in SL

- Sold objects are usually copyable or transferable, but rarely both.

- If you are buying something as a gift, make sure you will have transfer permissions

- BUYER BEWARE! Some less-than-honest people like to find free items that other people have made and sell them to unsuspecting new residents. You can always check who the creator is by looking at the object's properties. If you have doubts, IM the creator.

________________________________________

Q> "How do I use a vending machine?"

Usually most vending machines have an arrow or two, which lets you navigate forward or back through the list of items it is offering for sale.

Some may not have arrows, but will go to the next item when you left-click on the picture.

In most situations, to make a vending machine purchase:

- right click on the picture of the item you want

- select "Pay" from the pie menu

- type in the amount you want to pay

- This is your last chance to change your mind. Click the "Pay" button if you are sure you want to buy.

- accept the item from the blue dialog box

Be sure to accept the object when prompted. If you do not, you will not get the item, and you will not be refunded by the vendor!

________________________________________

Q> "Where do I go for lots of free stuff?"

- the "Library" folder of your inventory

- the Bazaar in Stillman: [? ]

________________________________________

Q> "I purchased something, but all I have is a box (or bag)?"

In SL, every prim has its own inventory which can contain other objects. Sometimes people use this as a way to sell items.

To get the stuff out of its container:

- go to a place where you can build

- drag the container from your inventory to the ground

- right click the container

- choose "Open" from the pie menu

- in the next window, select “copy contents to my inventory” OR “copy contents to my inventory and wear” if you want to wear your new purchase immediately

- don’t forget to right click on the empty bag or box you opened on the ground and select “delete” or “take” to take it back into your inventory.

________________________________________

Q> "I just teleported, but I'm not where I should be"

SL doesn't let you teleport directly to your destination. Instead, you will arrive at the "Telehub" nearest your destination, and then you will have to fly or walk toward the red beacon which marks where you intended to go.

If you have a friend who is already at the place you're going to, ask them to offer you a teleport. These teleports *will* take you directly to your friend.

________________________________________

Q> "How do I build?"

Building is a bit of an art, but to get started down your path to master 3D builder, you need to know some basics. In Second Life, we build with primitive 3D shapes, usually we just call them 'prims'. Some of the primitive shapes you can build with include: cube, sphere, cylinder, and torus. Arranging these shapes and then scaling, cutting, and twisting them into modified shapes will give you a great deal of flexibility even though you're starting from these very basic shapes.

To begin building:

- go to an area where you are permitted to build (i.e. a sandbox)

- right-click on the ground

- select "Create" from the pie menu; this opens the Edit window in create mode

- pick a prim shape you would like to create from the top of the Edit window

- left-click on the ground to 'rez' the shape

- your Edit window will then change to editing mode

- open up the edit window completely by clicking on the ( More >> ) button if you haven't done so already

The General tab is where you set object name, description, permissions, and the details for selling the object if you are putting it up for sale.

The Object tab is where you will edit the numbers associated with the object's shape, position, size, etc.

The Content tab displays a list of objects which are contained inside this object. This is where you will add scripts, sounds, animations, and other assets which you usually use in combination with a script, or for when you are using this object to sell its contents.

The Texture tab lets you set and adjust the texture and color of the object.

Some basic things to try while editing:

- Move the object back and forth with the red, blue, and green arrows.

- Holding down Shift while moving the object makes a copy.

- Holding down Ctrl will shortcut you to rotating the object.

- Holding down Shift+Ctrl will shortcut you to resizing the object.

- To combine two or more prims into one solid object, you "link" them under the menu Tools > Link.

- Once you've linked objects together, if you want to edit just one prim while still linked, check "Edit linked parts' in the edit menu.

- When you are done and want to keep the object, right click it and choose "Take" from the pie menu; it will then be placed in your inventory in the Objects folder.

- Pressing the Del key will delete the currently selected object(s).

- If you are building in a sandbox, please remember to take or delete everything when you are done.

For a more thorough introduction to building, attend a building class (check events), or visit the

[? ] for a self-guided tutorial.

________________________________________

Q> "How do I become a landowner?"

You must have a Premium subscription to own land. If you have a Basic account, you can change it to Premium at:

http://secondlife.com/account

If you're looking for land in-world, use the Find panel to search for a good deal on a parcel.

You can also bid on newly released land from a land auctioning system at:

http://secondlife.com/auctions

Once you have found a plot you want to buy:

- Go to the land you intend to buy.

- Enable parcel border display with the 'P' key.

- Right click the ground inside the parcel you want to buy.

- Choose 'About Land' from the pie menu.

- Click the 'Buy Land' button.

Note: If you have never owned land before, you will probably want to check out the "First Land" program, where you can get 512m for a very cheap price of L$512. Once you own land, you will never be able to enjoy the "First Land" offer again.

Caution: Be wary of land speculators who want to buy your First Land and exploit your newness to the world to make a profit. Check out the current average land prices at the URL below before negotiating any land sales.

To find out more about land, visit:

http://secondlife.com/land

________________________________________

Q> "How far away can people hear what I say in local chat?"

- 20 meters for normal chat

- 100 meters for shouts

________________________________________

Q> "Why is some chat text white and some grey?"

The darker text is from people chatting who are further away from you than the lighter shaded text.

________________________________________

Q> "How do I see what someone said earlier in local chat?"

Press Ctrl+H to open your chat history window. From there you can also scroll back and select text to copy/paste. Or click the “history” button in the bottom left corner of your screen

________________________________________
Q> “How do I talk to others in SL?

You have three modes of communications within Second Life, “chat”, “instant messaging”, and “voice communication”. To chat with someone, click the “chat” button at the bottom of your screen to view the chat window. Type in this window and others within 20 meters will be able to read your chat after you press the return key. If you type in the chat window and click “shout” then those up to 200 meters will be able to read your chat message. Instant messaging is done between individuals or groups and only those selected can read the message. To instant message someone, you can either click “communications” and choose that person’s name and click IM to send that person a message OR if you are near that person, right click on his or her avatar and select IM from the pie wheel and type a message to him or her. Only he or she will be able to read your message. To use voice communication, you will need to enable voice and must have a headset connected to your computer for best results. It is impolite to transmit voice all the time so it is recommended that you use “push to talk”. Whenever you want to talk to someone, push the “talk” button and you will see green waves coming from each side of the white dot floating above your head (this lets you know you are transmitting sound). When you are finished talking, release the “talk” button. If you will be talking for an extended period, push the small padlock next to the talk button and you will transmit sound continuously. Again, this is not recommended because people will hear everything you say and do which is considered rude in SL.

Q> "What are some of the basic social rules here?"

Second Life is an online community of adults (you must be 18 or older to participate). Due to this standard, it is expected that people will behave maturely and respectfully to their fellow residents. Here are some guidelines for standard etiquette in Second Life:

- Regions are indicated as either (M) or (PG) at the top of the screen. In PG regions, you should refrain from speech, behavior, sounds, or images which would not be acceptable to a general audience (similar to broadcast television or a PG rated movie). In Mature regions, mostly anything goes except the most extremely offensive content.

- Don't push other people around. Apologize if you do.

- Don't shoot at people unless they are voluntarily participating in a game with you. If you're looking for people to gunfight with, go to the Jessie or Rausch regions.

- Don't sell stuff that's already Free to Copy.

- If you are building in a sandbox, share the space and prims. Clean up after yourself when you leave. Do not sell anything in the sandboxes. Do not "test" your scripts on other people without asking them first.

- Playing sounds is fun, but try to limit playing the same sounds over and over again. Keep in mind that sounds also apply to the PG/M content rating rule.

For the exact rules, read the Terms of Service and Community Standards pages on the official website at:

https://secondlife.com/tos.php

https://secondlife.com/comstandards.php

________________________________________

Q> "How do I script something?"

If you are familiar with programming, the Linden Scripting Language should be easy to pick up in a short time. LSL is a compiled language which relies on events to trigger behaviors, with over 300 API functions to allow you to interact with the environment and the people in it.

The absolutely best reference for LSL is the LSL Wiki at:

http://secondlife.com/badgeo/

If you are not familiar with programming, LSL is a great language to start with; however, you may want to pick up a book to learn some of the basics of all programming languages (i.e. variables, functions, boolean logic, conditionals, loops, etc.) to help build a foundation.

Sometimes the best way to learn is to find example scripts, and jump in and just start changing them around to see what happens.

You can find a bunch of free scripts on the Second Life "Scripting Library" forum at:

http://forums.secondlife.com/forumdisplay.php?f=15

If you have any questions with scripting, try asking Live Help, or post them to the "Scripting Tips" forum at:

http://forums.secondlife.com/forumdisplay.php?f=54

Included with this FAQ is my scripting tutorial [? ], which I've composed from my lecture notes from back when I taught official scripting classes. This guide (like the class) was designed to be informative to both programmers and non-programmers alike, and should hopefully help you get started if you are new to scripting LSL =)

________________________________________

Q> "What does that abbreviation mean?"

Here are some common abbreviations that are mostly unique to Second Life:

SL - Second Life

LL - Linden Lab; the company who made SL

RL - Real Life; the meta-place where you need food, restroom breaks, etc

FL - same as RL (unless they mean Florida)

L$ - Linden Dollars; the virtual currency

AV - Avatar, your second life "body"

LH - Live Help; a group of volunteer residents who help people with questions

LSL - Linden Scripting Language; the language used to program objects in SL

GOM - Gaming Open Market; a currency exchange site

________________________________________

Q> "I joined a group, and now I have a title in front of my name, how do I remove it?"

- Open the "Edit" menu

- Select "Groups..."

- Scroll to the top

- Select "none"

- Click the "Activate" button

________________________________________

Q> How do I set my profile picture?

- Upload an image under the File menu, this will cost L$10

- Locate the image you uploaded in your inventory. It should be in the "Textures" folder.

- Open up your profile window by selecting "Profile..." from the Edit menu

- Drag and drop the image from your inventory's textures folder to the profile picture slot in your profile window

________________________________________

Q> "How should I set my Preferences?" / "What does this Preferences setting do?"

To open the preferences panel, press Ctrl+P or choose 'Preferences' under the Edit menu.

________________________________________

Q> "What if my question isn't answered in this FAQ?"

If you have any questions which aren't answered here, try the following:

- Select the menu "Help" > "Live Help" to query a group of volunteer residents

- Teleport to the [?] and ask your question in local chat

- Search through the forums, or create a new post with your question at:

http://forums.secondlife.com

- If you are familiar with IRC, try asking on efnet #secondlife

- Send an email to Second Life's official support address:

support@secondlife.com

________________________________________
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Welcome to Second Life!  There can be a lot of debate about if Second Life (SL) is really a game.  There are no mandated goals, we can do as much or as little as we like.  Having no goals is a bit hard to get used too, but you will soon see the freedom it allows us.  I see SL more a "place" to play, rather than a game.  It is the place to create a whole other life than your RL (real life).   

I have put together a list of tips that I find myself teaching new players all the time.  I hope these tips get you off to a good start. 

Please spend the time to read the notes, as a few minutes now will save you loads of head scratcing later on :)

First and foremost, EXPLORE.  It is a big world and there is plenty to see.  Keep in mind that most everything you see has been created by the residents.  The Lindens give us the servers as a canvas.  They have made the welcome area, the telehubs, and a few structures, but about 95 - 98% of what you see is made by us, the residents.  Exploring the world, meeting people and seeing what they are working on, will help you with ideas on what you may like to attempt to do.

As you explore, ask questions of people you meet.  Many are happy to help out and show off their work.  Feel free to explore someones build if they are not around.  Most are proud of their work and happy your interested in seeing it.  But, if the door is locked or the land is restricted, respect the owners decision on this and just move along and see what else their is to see.

While exploring, you may encounter people that may be too busy to give you their full attention.  Respect the fact that they are busy and move along if your not welcomed warmly.  Dont take it personally, building and scripting can take a lot of concentration at times.

Some SL exclusive terms you'll see...

AV, avatar.  Your body, who you are, the appearance of your AV can be changed almost infinately. 

IM, instant message.  IM button is at bottom left of the screen, use this to send a private message to someone, online or offline.  If your IM button is flashing, someone is sending you a message.

SIM, simulator, or server.  a SIM is a region of the world.

PRIM, primitive.  A PRIM is a basic building block.

REZ, to create something.  If you take something out of your inventory, you have "rezzed" it.

TP, teleport.  People will often ask you to offer them a TP to your location so they can join you.  Find this option in the persons profile.  You can ask someone to TP you to them.  

LM, landmark.  A LM is a place located in a sim.

HUB, TELEHUB, and TH, a telehub is a teleport destination.  When you choose to TP somewhere, you will arrive at the nearest HUB to the destination, then you can fly or walk the rest of the way.

L$ and US$, Linden Dollars (in world money) and US Dollars.

RL and FL, real life and first life.  Places that interfere with SL :-)

Now for a few tips...

*Chat History.  In big groups, when chat is scrolling pretty fast, chat history can help you get caught up.  The command to open chat history is, (CTRL + h).

*Hold your mouse cursor on anything and everything to see what it is.  If you hold your cursor on something, a tool tip will appear and show you a short description of it.  You can right click on it to see even more details of it.

*Right click on other AV to see their profile, you can often learn some basic information about the AV without asking.  Fill out your profile, let others know a little something about you.   Right click your AV to see what you can do. 

*You will acquire a lot of "stuff" in SL.  All of it lives in your Inventory, until you "rez" it.  To wear clothing, drag the item from inventory to your AV (or simply click "wear").  Keeping your inventory organized is a lot like keeping your documents organized, create folders where you need to. 

*Saving your AV look.  You can have many different AV looks, simply save them as outfits.  Right click yourself and go to appearance mode.  At the bottom left, you can "make outfit".  To save a whole AV, be sure to include the body parts, your shape, skin, hair, and eyes.  Include the clothes and attachments.  Then, name the "outfit" and save.  This folder will be saved to your clothing folder.  You can simply drag the folder from your inventory to your AV to change in an instant.

*Removing contents from boxes.  Things you buy or aquire often come packed in boxes.  To remove the contents, drag the box from your inventory to the ground in front of you.  EDIT the box and select MORE to see the details and click on CONTENTS.  Then simply drag the contents from the box to your inventory.  Once in your inventory, you can use the objects.  It is okay to delete the box the contents came in once you have transferred the contents to your inventory.

*Setting LM's.  If you find a place you like, you can set a LM so you can find it again.  Select WORLD button at top and  "Create Landmark Here".  You might need to rename it, once in your inventory, to remind yourself why you made the LM.

*Force Daylight.  While night is often very nice, it can be hard to work in the dark.  You must have your DEBUG menu (located at top next to HELP menu) enabled to force daylight.  To toggle DEBUG on and off, press these keys, (alt + ctrl + shift + d).  ALT + N is the command to make night day.  Explore your debug options, lots of things you can do to change how you see the world.

*Snapshot to Disk.  Snapshots in game cost L$10.  But, you can send high resolution pic to your hard drive for free.  The ( ` )  key (above TAB) is default key for this.  You can then later review your pics and decide which ones you would like to upload into world.

*View options for seeing land.  If you are looking for land, use VIEW to show PROPERTY LINES and LAND OWNERS.  This makes the actual plots more easy to identify.

*Visit the forums regularly.  The forums are a good pulse of the community.  You can see ideas and projects others have and it is a good knowledge resource.

http://forums.secondlife.com and for searching the forums... http://forums.secondlife.com/search.php

*Want to know more about building in SL? Why not the Ivory Tower of Primitives in Noyo - €
or attend a Basic Building class/event (these are held almost every day, so check the Events listing)

*If you are struggling with scripting and finding the Linden manual not too helpful why not try: http://www.tyrellcorporation.org/disabled/HomePage or http://lslwiki.sdfjkl.org/ for a scripting resource

*If you need an injection of money to buy land or whatever else you can buy and sell Linden dollars for US dollars via the Gaming Open Market (http://www.gamingopenmarket.com). There are installed inworld ATM systems dotted around SL to deposit and withdraw those Linden dollars.

*If you have upgraded your basic account to a premium account and don't have any land yet, you qualify for the Land of Landless program. To get a new plot of land, simply use Find -> Land Sales and change the drop down from all to First Land then do a search for a new plot!

*Don't forget to pick up a copy of the inworld SL magazine, available at the information stand on the main campus here and many other locations around SL.

And finally, EXPLORE and have fun!    

Clothing and appearance are two of the first things on the minds of most new residents of SL (aka: Newbies or Noobs).   

Appearance - 

Your AV (Avatar) appearance can be changed almost infinitely, you don't even have to be human (aka "fleshy".)   Change your appearance by right clicking on your AV and choosing "Appearance".   Change your hair, skin, eyes, body shape, etc...  

Ladies: many of the high fashion shoes you will buy in SL require a foot size of 0, so you might want to just set that as your default.  There are places in SL to buy other AV's already made, such as animals and robots.  

Clothing - 

All new residents arrive at the SL welcome area wearing a basic uniform.  All these items are stored in your "inventory"; you will find the "Inventory" button on the bottom right hand corner of your screen.  Wear clothing by clicking on it and choosing "wear" or by dragging it over to your AV.   When you purchase clothing in SL it will come to you in one of several ways.  Sometimes the clothing is added right into your inventory as a folder or individual item. Often times, purchases come in a "box" that you need to unpack.  

Here is a step by step instruction.

1.  Drag the box out of your inventory to the floor next to you. 

2.  Go to Edit mode (under Tools, then edit or right click on the box and choose edit)

3.  Once in the Edit window, make sure you have selected "Move".

3.  Hit the tab "More" at the bottom right corner of the window.

4.  Go to the tab "Contents"

5.  Drag the clothing icon from the box to your Inventory, "Clothing"  

6.  Drag the clothing item from the Inventory file to your Avatar  OR, you can just double click the clothing it will go directly to your Avatar.

7.  Go to Appearances and adjust the clothes and attachments to fit how you like.

8.  Make a new file while in appearances,  Bottom of screen is a button that says "Make Outfit".  Press and select what you want in this file.

9.  Close all the windows.

10.  Pick up the box, you are ready to go!  Always take your boxes with you, it is considered rude here in SL to leave garbage in other people's land.  You can delete the box from your inventory. 

Managing your Inventory - 

Think of your inventory the same way you would the "my documents" folder on your computer.  Make new folders, rename things, and organize your inventory so you can find things.  You will acquire a LOT of stuff here in SL. Many of those items will be placed in the "objects" folder of your inventory. 

